$re = '/((?:\d,)+?)\1+$|((?:\d,)+)((?:\d,)*?)\2+|((?:\d,)+)/m';
$str = '1,2,3,4,1,2,3,4,5,6,5,6,5,6,
2,3,1,2,3,1,1,2,3,4,
2,3,1,1,2,3,4,2,3,1,
1,2,3,1,2,3,1,2,3,1,2,3,
6,6,6,6,6,6,6,6,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);