$re = '/([^?=&]+)(=([^&]*))?/';
$str = '?a=1&b=&c&D123=Hello world';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);