package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[0-9]\ ([A-Za-z]*)$`)
var str = `24159 Kiel`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}