$re = '/\'/m';
$str = '"you can use single \\\'\' or double \\" quote this Mc\'Garrett"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);