$re = '/^v(\d+\.)?(\d+\.)?(\*|\d+)$/';
$str = 'v1.0.1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);