#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.(.(?1).|.?)$"
Local $sString = "x" & @CRLF & _
"xx" & @CRLF & _
"xxx" & @CRLF & _
"xxxx" & @CRLF & _
"xxxxx" & @CRLF & _
"xxxxxx" & @CRLF & _
"xxxxxxx" & @CRLF & _
"xxxxxxxx" & @CRLF & _
"xxxxxxxxx" & @CRLF & _
"xxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"" & @CRLF & _
"..." & @CRLF & _
"" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")