$re = '/(?<=^|\s)\b\d+([\/-]?\d)*(?<!\/|-)(с{1,2}|дсп)?\b(?=\s)/mu';
$str = '12/2с 12/2-2с 1-2/3дсп
аб12/2с 12/2-с 12/с 12/2-2ссс';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);