$re = '/(\-?\d+\.?\d?)[C]/m';
$str = '24 Jul 2013: Water - 74.0F / 23.3C; Air - 68.0F / 20.0C. John L. helped out a wounded cyclist; Anthony C. swam 1km';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);