$re = '/.*\s-\s/';
$str = '20023la - 100 lt storage cylinder RBA100 - 1120820';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);