#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "assertEquals\(([^,]+),\s(.+)\);"
Local $sString = "package com.gdit.fwa.informant.model.definitions;" & @CRLF & _
"" & @CRLF & _
"import static org.junit.Assert.assertEquals;" & @CRLF & _
"" & @CRLF & _
"import org.junit.Test;" & @CRLF & _
"" & @CRLF & _
"import com.gdit.fwa.informant.model.base.definition.RelationalOperator;" & @CRLF & _
"import com.gdit.fwa.informant.model.base.definition.SqlConstants;" & @CRLF & _
"" & @CRLF & _
"@SuppressWarnings("static-method")" & @CRLF & _
"public class RelationalOperatorTest {" & @CRLF & _
"" & @CRLF & _
" @Test" & @CRLF & _
" public void testGetRelOperatorSql() {" & @CRLF & _
" assertEquals(RelationalOperator.DEFAULT.getRelOperatorSql(), "");" & @CRLF & _
" assertEquals(RelationalOperator.IS.getRelOperatorSql(), "IS");" & @CRLF & _
" assertEquals(RelationalOperator.IS_NOT.getRelOperatorSql(), "IS NOT");" & @CRLF & _
" assertEquals(RelationalOperator.EQUAL.getRelOperatorSql(), "=");" & @CRLF & _
" assertEquals(RelationalOperator.NOT_EQUAL.getRelOperatorSql(), "<>");" & @CRLF & _
" assertEquals(RelationalOperator.GREATER_THAN.getRelOperatorSql(), ">");" & @CRLF & _
" assertEquals(RelationalOperator.LESS_THAN.getRelOperatorSql(), "<");" & @CRLF & _
" assertEquals(RelationalOperator.GREATER_EQUAL.getRelOperatorSql(), ">=");" & @CRLF & _
" assertEquals(RelationalOperator.LESS_EQUAL.getRelOperatorSql(), "<=");" & @CRLF & _
" assertEquals(RelationalOperator.BETWEEN.getRelOperatorSql(), "BETWEEN");" & @CRLF & _
" assertEquals(RelationalOperator.IN.getRelOperatorSql(), "IN");" & @CRLF & _
" assertEquals(RelationalOperator.NOT_IN.getRelOperatorSql(), "NOT IN");" & @CRLF & _
" assertEquals(RelationalOperator.LIKE.getRelOperatorSql(), "LIKE");" & @CRLF & _
" assertEquals(RelationalOperator.NOT_LIKE.getRelOperatorSql(), "NOT LIKE");" & @CRLF & _
" assertEquals(RelationalOperator.SOUNDS_LIKE.getRelOperatorSql(), "SOUNDS LIKE");" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @Test" & @CRLF & _
" public void testGetRelationalOperator() {" & @CRLF & _
" assertEquals(RelationalOperator.DEFAULT, RelationalOperator.getRelationalOperator(""));" & @CRLF & _
" assertEquals(RelationalOperator.IS, RelationalOperator.getRelationalOperator("IS"));" & @CRLF & _
" assertEquals(RelationalOperator.IS_NOT, RelationalOperator.getRelationalOperator("IS NOT"));" & @CRLF & _
" assertEquals(RelationalOperator.EQUAL, RelationalOperator.getRelationalOperator("="));" & @CRLF & _
" assertEquals(RelationalOperator.NOT_EQUAL, RelationalOperator.getRelationalOperator("<>"));" & @CRLF & _
" assertEquals(RelationalOperator.GREATER_THAN, RelationalOperator.getRelationalOperator(">"));" & @CRLF & _
" assertEquals(RelationalOperator.LESS_THAN, RelationalOperator.getRelationalOperator("<"));" & @CRLF & _
" assertEquals(RelationalOperator.GREATER_EQUAL, RelationalOperator.getRelationalOperator(">="));" & @CRLF & _
" assertEquals(RelationalOperator.LESS_EQUAL, RelationalOperator.getRelationalOperator("<="));" & @CRLF & _
" assertEquals(RelationalOperator.BETWEEN, RelationalOperator.getRelationalOperator("BETWEEN"));" & @CRLF & _
" assertEquals(RelationalOperator.IN, RelationalOperator.getRelationalOperator("IN"));" & @CRLF & _
" assertEquals(RelationalOperator.NOT_IN, RelationalOperator.getRelationalOperator("NOT IN"));" & @CRLF & _
" assertEquals(RelationalOperator.LIKE, RelationalOperator.getRelationalOperator("LIKE"));" & @CRLF & _
" assertEquals(RelationalOperator.NOT_LIKE, RelationalOperator.getRelationalOperator("NOT LIKE"));" & @CRLF & _
" assertEquals(RelationalOperator.SOUNDS_LIKE, RelationalOperator.getRelationalOperator("SOUNDS LIKE"));" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @Test" & @CRLF & _
" public void testRelOpEqualityFunctions() {" & @CRLF & _
" for (RelationalOperator relOp : RelationalOperator.values()) {" & @CRLF & _
" if (relOp == RelationalOperator.IS || relOp == RelationalOperator.IS_NOT){" & @CRLF & _
" assertEquals(relOp.isEquality(), true);" & @CRLF & _
" assertEquals(relOp.getNullLogicOperator(), SqlConstants.OR);" & @CRLF & _
" assertEquals(relOp.getNullRelOperator(), RelationalOperator.IS);" & @CRLF & _
" assertEquals(relOp.getRelOperatorFilterSql(), RelationalOperator.IN.getRelOperatorSql());" & @CRLF & _
" } else {" & @CRLF & _
" assertEquals(relOp.isEquality(), false);" & @CRLF & _
" assertEquals(relOp.getNullLogicOperator(), SqlConstants.AND);" & @CRLF & _
" assertEquals(relOp.getNullRelOperator(), RelationalOperator.IS_NOT);" & @CRLF & _
" assertEquals(relOp.getRelOperatorFilterSql(), RelationalOperator.NOT_IN.getRelOperatorSql());" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @Test" & @CRLF & _
" @SuppressWarnings("deprecation")" & @CRLF & _
" public void testGetNullValue() {" & @CRLF & _
" assertEquals(RelationalOperator.getNullValue(), SqlConstants.NULL);" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @Test" & @CRLF & _
" public void testGetNullClause() {" & @CRLF & _
" for (RelationalOperator relOp : RelationalOperator.values()) {" & @CRLF & _
" switch (relOp) {" & @CRLF & _
" case IS:" & @CRLF & _
" case EQUAL:" & @CRLF & _
" assertEquals(relOp.getNullClause("Test"), " OR Test IS null");" & @CRLF & _
" break;" & @CRLF & _
" case IS_NOT:" & @CRLF & _
" case NOT_EQUAL:" & @CRLF & _
" assertEquals(relOp.getNullClause("Test"), " AND Test IS NOT null");" & @CRLF & _
" break;" & @CRLF & _
" default:" & @CRLF & _
" assertEquals(relOp.getNullClause("Test"), "");" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
""
Local $sSubst = "assertEquals\($2\, $1\);"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)