const regex = /(?P<datetime>\d{2}\/\d{2}\/\d{2} \d{2}:\d{2}:\d{2}): (?P<name>\w+(?::\s*\w+)*|[\w\s]+?)(?:\s+(?P<action>joined|left|was removed|changed the (?:subject to “\w+â€|group icon))|:\s(?P<message>(?:.+|\n(?!\n))+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<datetime>\\d{2}\\\/\\d{2}\\\/\\d{2} \\d{2}:\\d{2}:\\d{2}): (?P<name>\\w+(?::\\s*\\w+)*|[\\w\\s]+?)(?:\\s+(?P<action>joined|left|was removed|changed the (?:subject to “\\w+â€|group icon))|:\\s(?P<message>(?:.+|\\n(?!\\n))+))', 'g')
const str = `29/03/14 15:48:05: John Smith changed the subject to “Testâ€
29/03/14 16:10:39: John Smith joined
29/03/14 16:10:40: Person:2 joined
29/03/14 16:10:40: John Smith: Hello!
29/03/14 16:11:40: Person:2: some random words,
29/03/14 16:12:40: Person3 joined
29/03/14 16:13:40: John: Smith: Hello!Test message with newline
Another line of the same message
Another line.
29/03/14 16:14:43: Person:2: Test message using as last word joined
29/03/14 16:15:57: Person3 left
29/03/14 16:17:16: Person3 joined
29/03/14 16:18:21: Person:2 changed the group icon
29/03/14 16:19:16: Person3 was removed
29/03/14 16:20:43: Person:2: Test message using as last word left`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}