#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?P<datetime>\d{2}\/\d{2}\/\d{4},\s\d(?:\d)?:\d{2} [pa].m.)\s-\s(?P<name>[^:]*):(?P<message>.*)"
Local $sString = "15/11/2017, 10:59 p.m. - βͺSome random nameβ¬: Thats sounds like crow who don't know marathiπ€£" & @CRLF & _
"15/11/2017, 11:00 p.m. - Pratik: ππ" & @CRLF & _
"15/11/2017, 11:00 p.m. - Dhiraj Kadam: Msging language bruhπππ" & @CRLF & _
"15/11/2017, 11:00 p.m. - Rushiraj Msc: ππππ" & @CRLF & _
"15/11/2017, 11:00 p.m. - Shreyas : π©π©π©" & @CRLF & _
"15/11/2017, 11:01 p.m. - Abhisek Joshi: ππ" & @CRLF & _
"15/11/2017, 11:01 p.m. - βͺSome Name: Age piche ke students 2 ... 2 subject padho and copy.. nahi ata to thoko bhindhass" & @CRLF & _
"15/11/2017, 11:01 p.m. - Shreyas : ππΌππΌππΌππΌπ―" & @CRLF & _
"15/11/2017, 11:02 p.m. - βͺSome name: Respect the term autonomous" & @CRLF & _
"15/11/2017, 11:02 p.m. - βͺSome Name : Gharguti ...π
" & @CRLF & _
"14/11/2017, 9:54 a.m. - Abhisek Josh: πππ" & @CRLF & _
"14/11/2017, 10:37 a.m. - βͺSOme Name: Do you still remember those awkward days in schools during Exams ?" & @CRLF & _
"" & @CRLF & _
"When a bright student tells the invigilator that question 4 has a problem, but you have already answered it...π³π" & @CRLF & _
"" & @CRLF & _
"When a fellow student asks for a graph paper, but you are finished and did not see anywhere where it was required...π§ ππ" & @CRLF & _
"" & @CRLF & _
"When the invigilator says jump question 6 we will rectify it later, but it was the question you enjoyed most when answering...π π±π²" & @CRLF & _
"" & @CRLF & _
"When you see people busy using rulers and you are wondering what is going on...π£π«π«" & @CRLF & _
"" & @CRLF & _
"When you hear your friends arguing after the exam whether the answer to question 5 was 35.5% or 36.5% and your answer was 1800 π©π" & @CRLF & _
"" & @CRLF & _
"The cream. When the other students asked for 4-5 additional answer sheets and You had two pages empty in the main answer sheetπ¨π°π±" & @CRLF & _
"" & @CRLF & _
"See where you have reached in life inspite of those moments...things are not permanent...enjoy life! ππ" & @CRLF & _
"" & @CRLF & _
"Only for those who enjoyed their school lifeπππ" & @CRLF & _
"" & @CRLF & _
"Top 10 Dialogue of teacher" & @CRLF & _
"π If you are not interested then you may leave the class." & @CRLF & _
"π This class is worse than a fish market." & @CRLF & _
"π Are you here to waste your parents money? " & @CRLF & _
"π Tell me when you all have finished talking." & @CRLF & _
"π Why are u laughing? Come here n tell us we'll also laugh. " & @CRLF & _
"π Do you think teachers are fools to teach you?" & @CRLF & _
"π Don't try to act oversmart with me." & @CRLF & _
"π Why do u come to school when you don't want to study." & @CRLF & _
"π The previous batch was 100 times better than yours." & @CRLF & _
"π If you want to talk then u may get out from the class." & @CRLF & _
"" & @CRLF & _
"And the best one" & @CRLF & _
"π You yes you... I am talking to you only, don't look back.. ππ" & @CRLF & _
"." & @CRLF & _
"." & @CRLF & _
"." & @CRLF & _
"I'm sure that the last line made all of you remember and smile ." & @CRLF & _
"14/11/2017, 10:42 a.m. - βͺNameβ¬: πππ" & @CRLF & _
"14/11/2017, 11:15 a.m. - Sanesh Sagvekar: Whos in clg now" & @CRLF & _
"14/11/2017, 11:15 a.m. - Sanesh Sagvekar: πππππΌππΌππΌ"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")