$re = '/@\K[\w.]+/m';
$str = '1 blah blah blah @username_. sblah sblah sblah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);