$re = '/^\w{1,14}$/m';
$str = 'magento_media
magento
magento.sh
magento>media
magento:media
magento&media
/magento
/magento/media';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);