import re
regex = re.compile(r"\/(.*?)\/?$", flags=re.MULTILINE)
test_str = "gsgs/lslsls/ssl;sl"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)