# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:N\d|N\d{2}|(?:EX|N|P|V8|XU)\d{3}|(?:B|CP|CU-T|HL|JA|JU|N|OB|OE|OK|RPC|V7|VN|YV)\d{4}|(?:4K|4L|B|EK|ER|EW|EX|EY|N|RA|RDPL|UK|UN|UR)\d{5}|RA\d{4}K|VN[A-Z]\d{3}|4K[A-Z]{2}\d{2}|(?:4L|UR)[A-Z]{3}|XC[A-Z]{3}\d{2}|(?:HJ|HK|N)\d{4}[A-Z]|HP\d{4}[A-Z]{3}|(?:JA|N|YV)\d{3}[A-Z]|(?:EW|HI|N)\d{3}[A-Z]{2}|N\d{2}[A-Z]|(?:JA|N)\d{2}[A-Z]{2}|N\d[A-Z]|N\d[A-Z]{2}|(?:EZ|JA|OK)[A-Z]\d{3}|(?:9XR|A4O|A9C|B-H|B-K|B-L|B-M|F-OD|F-OG|F-OH|OY-B|OY-H|OY-X|VP-A|VP-B|VP-C|VP-F|VP-G|VP-L|VP-M|VQ-H|VQ-T)[A-Z]{2}|(?:4K|HZ|V8|YJ)[A-Z]{2}\d|(?:HZ|YJ)[A-Z]{2}\d{2}|(?:3A|3B|3C|3D|3X|4O|4R|4U|4X|5A|5B|5H|5N|5R|5T|5U|5V|5W|5X|5Y|6O|6V|6W|6Y|7O|7P|7Q|7T|8P|8Q|8R|9A|9G|9H|9J|9K|9L|9M|9N|9Q|9U|9V|9Y|A2|A3|A5|A6|A7|A8|A9C|AP|C2|C3|C5|C6|C9|CC|CF-|C-F|C-G|C-I|CN|CR|CS|CX|D2|D4|D6|DQ|E3|E5|EC|EI|EP|ER|ES|ET|F-O|H4|HA|HB|HC|HH|HR|HS|HZ|J2|J3|J5|J6|J7|J8|JY|LN|LQ|LV|LX|LY|LZ|OD|OE|OH|OK|OM|OO|OY|OY|OY|P2|P4|PH|PJ|PK|PP|PR|PT|PU|PZ|S2|S5|S7|S9|SE|SP|ST|SU|SX|T2|T3|T7|T9|TC|TF|TG|TI|TJ|TL|TN|TR|TS|TT|TU|TY|TZ|V2|V3|V4|V5|V6|V8|VH|VT|XA|XB|XC|XT|XY|XZ|YA|YI|YK|YL|YN|YR|YS|YU|Z|Z3|ZA|ZK|ZL|ZM|ZP|ZS|ZT|ZU)[A-Z]{3}|HZ[A-Z]{3}\d|OK[A-Z]\d{2}|(?:D|F|G|I|M)[A-Z]{4}|YV(?:KW\d|O\d{3}|SATA\d))$"
test_str = "N5441V"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.