package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<a.*?href=\"(.+.pdf\?min)\".*?>(.*?)<\/a>`)
var str = []byte(`<table cellspacing="0" cellpadding="0" width="100%" border="0">
<tbody>
<tr>
<td width="25%"><a href="http://www.test.com/myfile.pdf?min" target="_blank">Menus 18 €</a></div></td>
<td width="25%"><a href="http://www.test.com/myfile.pdf?min" target="_blank">Menus 24 et 26 €</a></div></td>
<td width="25%"><a href="http://www.test.com/myfile.pdf?min" target="_blank">Menus 30 et 37 € </a></div></td>
<td width="25%"><a href="http://www.test.com/myfile.pdf?min">La Carte détaillée <br>
(Entrées - Viandes - Poissons)</a></td>
</tr>
</tbody>
</table>`)
var substitution = []byte("ok")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}