use strict;
my $str = 'a a aaaainput 1.5e8 100 1e8 1000e3 1. .2 .3e-3 -3 +3 abcd 1 192.168.100.1 1 192.168. 1 .129.12 1.5 .3ee 1 .3e+e 1 3fgh 1 .3sdf 1 asdf3 0 asdf3asdf -111.555e-100 +99.99e+99
';
my $regex = qr/((?<![\w.])[+-]?(?:\d+\.\d+|\d+\.|\.\d+|\d+)(?:[eE][+-]?\d+)?(?![\w.]))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}