package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d{3}[ ]{0,1}\d{3}[ ]{0,1}\d{4}$`)
var str = `+123 456 7890`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}