$re = '~^(?:(?=[^\d\n]*\d)|^$).*~m';
$str = '12abcd
abd
abde13
cdjk2d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);