# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+)\D?of\D?\d+"
test_str = ("Hello 1 of 60\n"
"Hello.22.of.60.\n"
"Hello 33of60\n"
"Hello.44of60.\n"
"Hello 1 of 6\n"
"Hello.2.of.6.\n"
"Hello 3of6\n"
"Hello.04of6.\n\n")
subst = "S01E\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.