# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[\[(?:[^][]*|\[(?!\[)|\](?!\]))*+\]\]\K|\[\[ ?| ?\]\]"
test_str = ("Locate instances of nested double square brackets and remove the outer double square brackets\n\n"
"I'm using TextMate (but happy to use any suitable search and replace program) to query a set of files (these files are my notes in Logseq if its relevant).\n\n"
"I'm looking to find and replace instances of nested double square brackets and remove the outer double square brackets\n\n"
"eg 1 - Normal nesting\n\n"
" [[ any text or no text [[ any text ]] any text or no text]]\n"
" \n\n"
"eg 2 - Compound nesting \n\n"
" [[ any text or no text [[ any text ]] [[ any text ]] any text or not text ]]\n\n\n"
"eg 3 - multi-level nesting \n\n"
" [[ any text or no text [[ any text or no text [[ any text or no text ]] any text or no text]] any text or no text ]]\n\n"
"Note: keep in mind that the double square brackets could be touching. So example 1 could also manifest as\n\n"
" [[ any text or no text [[ any text ]]]]")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.