$re = '/foo[^.#]*bar/';
$str = 'foo 12345 bar
foo
12345
bar';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);