re = /^(?=.*?[0-9].*?[0-9])(?=.*[!@#$%])[0-9a-zA-Z!@#$%0-9]{8,}$ /m
str = 'asdfg
asd123678&*
#$%sdf1234
123asdf!@#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end