$re = '/((?<=\[)\w*(?=\])|(?<=@)\w*)/';
$str = '[tag1] [tag2] @user1 @user2 ignoreme';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);