const regex = /(?<!Above) & |(?i)(\s?)f(?:ea)?t(?:(?:\.?|\s)|uring)(?=\s)|\sx\s|_/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!Above) & |(?i)(\\s?)f(?:ea)?t(?:(?:\\.?|\\s)|uring)(?=\\s)|\\sx\\s|_', 'gm')
const str = `Selects all variations of Featuring
& unless preceeded by Above &
x
_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}