$re = '/^(.*?)here/m';
$str = 'i want to stop here, not here.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);