re = /(?'content1'.+)<delay=(?'delay'\d*\.?\d*)f>(?'content2'.*)/m
str = 'first thing<delay=1.4f>second thing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end