import re
regex = re.compile(r"(?<![^\/]\/)\b\w+\.\b\w{2,3}(?:\.\b\w{2})?(?=$|\/)", flags=re.MULTILINE)
test_str = ("https://domain.com\n"
"https://subdomain.domain.com\n"
"https://www.sub.sub.subdomain.domain.com\n"
"http://sub.masterdomain.com.au\n"
"https://four.submains.new.domain.luxury.co.uk\n"
"https://www.globo.us/games/tap-zap-boom/\n"
"https://www.test.com/games/socce/index.html\n"
"https://google.com.br/services/index.php\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")