import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\/dev\\/(sdf|xvd)[a-p][0-9]{0,1})\\s+([^\\s]+)\\s+([^\\s]+)\\s+([^\\s]+)\\s+([^\\s]+)\\%\\s+([^\\n]*)$";
final String string = "/dev/xvda1 7.8G 1.1G 6.4G 14% /\n"
+ "none 4.0K 0 4.0K 0% /sys/fs/cgroup\n"
+ "udev 284M 12K 284M 1% /dev\n"
+ "tmpfs 59M 192K 59M 1% /run\n"
+ "none 5.0M 0 5.0M 0% /run/lock\n"
+ "none 295M 0 295M 0% /run/shm\n"
+ "none 100M 0 100M 0% /run/user\n"
+ "/dev/xvdf 20G 102M 19G 1% /mnt/data\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}