$re = '/(\w*\d+\w*)/';
$str = 'To enter the building code is 123A.The access code is 456.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);