package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+(\b.*\b)`)
var str = `The tower is 100 meters tall.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}