import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\s\\S]*)<preview>([\\s\\S]*)";
final String string = "\n"
+ "Ðа Хабре уже были теÑты LTE-Ñети «МегаФон» в МоÑкве, тем не менее, Ñ Ð½Ðµ упуÑтил ÑÐ»ÑƒÑ‡Ð°Ñ Ð¿Ñ€Ð¾Ð²ÐµÑ€Ð¸Ñ‚ÑŒ её работу ÑамоÑтоÑтельно — и именно на новеньком iPad Air. \n\n"
+ "Удивительно дело, Ð¼Ð¾Ñ Xperia P на ТульÑкой ловит так, что Ð¾Ñ‚Ð²ÐµÑ‡Ð°Ñ Ð½Ð° звонки к окну приходитÑÑ Ð¿Ð¾Ð´Ñ…Ð¾Ð´Ð¸Ñ‚ÑŒ. Ð LTE на айпаде разогналÑÑ Ð´Ð¾ Ñовершенно гигантÑких, на уровне проводного интернета, ÑкороÑтей:\n\n\n\n"
+ "Впрочем, возможно дело в том, что в Ñ‡Ð°Ñ Ð½Ð¾Ñ‡Ð¸ нагрузка на Ñеть минимальнаÑ. Однако в разгар рабочего днÑ, пуÑть и пÑтницы, ÑÐ¸Ñ‚ÑƒÐ°Ñ†Ð¸Ñ Ñ‚Ð¾Ð¶Ðµ впечатлÑющаÑ:\n\n"
+ "<preview>\n\n\n"
+ "Рвот так выглÑдÑÑ‚ результаты замеров за поÑледние Ñутки в разных районах города — от КалужÑкой до ВойковÑкой: \n\n\n\n"
+ "Минимальный результат — на ÑÑкалаторе «ТретьÑковÑкой». При Ñтом в метро LTE, да и вообще Ñеть ловит далеко не на вÑех перегонах, но на ÑтанциÑÑ… работает иÑправно. \n\n"
+ "СоглаÑно данным иÑÑÐ»ÐµÐ´Ð¾Ð²Ð°Ð½Ð¸Ñ Â«Ð¢ÐµÐ»ÐµÐºÐ¾Ð¼ Дейли», проведенного в авгуÑте 2013, Ñеть 4G от МегаФона ÑвлÑетÑÑ Ñамой быÑтрой Ñетью 4G в МоÑкве и обладает Ñамой большой зоной обÑлуживаниÑ, Ð¾Ñ…Ð²Ð°Ñ‚Ñ‹Ð²Ð°Ñ Ð½Ðµ только территорию мегаполиÑа, но и пригороды. Ðтого пока не может обеÑпечить ни один другой оператор.\n\n"
+ "Официальные данные «МегаФон» таковы:\n\n"
+ "ÑреднÑÑ ÑкороÑть передачи данных в уÑловиÑÑ… дейÑтвующей Ñети в МоÑкве превышает 20 Мб/Ñек. Ðто в 7 раз выше, чем ÑреднÑÑ ÑкороÑть 3G — 3,2 Мб/Ñек в июле 2012\n"
+ "ÑкороÑть отклика (ping) почти вдвое быÑтрее, чем в 3G\n\n"
+ "Как ÑледÑтвие — ÑÐ¿Ñ€Ð¾Ñ Ð½Ð° поддерживающие 4G уÑтройÑтва будет только раÑти. Уже ÑÐµÐ¹Ñ‡Ð°Ñ 5% вÑех продаж в Ñалонах «МегаФон» — Ñмартфоны Ñ 4G, а в интернет-магазине компании – вÑе 8%. По прогнозам, во 2-3 квартале 2014 года до 50% Ñмартфонов на роÑÑийÑком рынке будут иметь поддержку LTE.\n\n"
+ "ТеоретичеÑки iPhone 5S/5C также поддерживает роÑÑийÑкие чаÑтоты LTE, но Ñ€ÐµÐ°Ð»ÑŒÐ½Ð°Ñ Ð²Ð¾Ð·Ð¼Ð¾Ð¶Ð½Ð¾Ñть их работы в ÑетÑÑ… 4G на данный момент заблокирована производителем. ТехничеÑки Ñеть «МегаФона» полноÑтью готова принÑть новые Ñмартфоны Apple, но Ð²Ð¾Ð¿Ñ€Ð¾Ñ Ð¿Ð¾Ð´Ð´ÐµÑ€Ð¶ÐºÐ¸ 4G-Ñетей находитÑÑ Ð² компетенции производителÑ.\n\n"
+ "При Ñтом развитие 4G благоприÑтно влиÑет и на дейÑтвующую Ñеть 3G: Ñ Ñ€Ð°Ñширением линейки уÑтройÑтв потребители «тÑжелого» контента будут вÑе чаще иÑпользовать 4G, выÑÐ²Ð¾Ð±Ð¾Ð¶Ð´Ð°Ñ Ñ€ÐµÑурÑÑ‹ Ð´Ð»Ñ 3G, Ð±Ð»Ð°Ð³Ð¾Ð´Ð°Ñ€Ñ Ñ‡ÐµÐ¼Ñƒ ÑкороÑть и в Ñтом Ñегменте будет раÑти.\n\n"
+ "Подключение\n\n"
+ "Чтобы наÑлаждатьÑÑ Ð²Ñеми радоÑÑ‚Ñми LTE поÑле Ð¿Ñ€Ð¸Ð¾Ð±Ñ€ÐµÑ‚ÐµÐ½Ð¸Ñ iPad Air или любого другого 4G-уÑтройÑтва вам понадобитÑÑ nanoSIM «МегаФон» Ñ Ð¿Ð¾Ð´Ð´ÐµÑ€Ð¶ÐºÐ¾Ð¹ 4G (USIM). ЕÑли у Ð²Ð°Ñ ÑƒÐ¶Ðµ еÑть microSIM Ñ Ð¿Ð¾Ð´Ð´ÐµÑ€Ð¶ÐºÐ¾Ð¹ LTE, то в Ñалоне «МегаФон» её обрежут беÑплатно. СтоимоÑть уÑлуг передачи данных у «МегаФона» Ð´Ð»Ñ 2G/3G/4G Ñетей едина, поÑтому лучше Ñразу подключить одну из интернет-опций «Интернет S/M/L/XL» (от 390 Ñ€. за 3 ГБ). \";\n";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}