package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([0-9]+)([a-záéíóúñ]{1})`)
var str = `3de`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}