#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!0+(?:[,.]0+)?$)\d+(?:[,.][05])?$"
Local $sString = "0,5" & @CRLF & _
"0.5" & @CRLF & _
"0.7" & @CRLF & _
"0,9" & @CRLF & _
"1,0" & @CRLF & _
"1.0" & @CRLF & _
"1.4" & @CRLF & _
"1,4" & @CRLF & _
"1.5" & @CRLF & _
"0" & @CRLF & _
"0,0" & @CRLF & _
"0000.000" & @CRLF & _
"00000,00000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")