$re = '/^(?=.*[aeiouAEIOU])(?=.*[A-Z])(?=.*\d)(?!.*(.)\1).*$/m';
$str = 'ThisIsMyyPassword20
IMissUK20
ThisIsMyPasword20
IMisUK20
IdontKnow20
IidontKnow20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);