$re = '/\+([0-9])([ .-]*\d){7,12}/';
$str = '+35388888888<script>alert(1)</script>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);