$re = '/(?<![0-9]\.)(?<![0-9])[0-9]+(?!\.?[0-9])|\b\p{L}\b/u';
$str = '1 2 3, но не 1.1 или 14.14 & а б в a b c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);