package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[a-z]+@\d+`)
var str = `|ABC@123|abc@123456|ABcD@12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}