# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<blockquote[^>]*>
[\S\s]*?
)<(b|h[2-5])\b[^>]*>([\S\s]*?)<\/\2>/\1<h6>\3<\/h6>/gmx;t' <<< "<blockquote>
<div>Stuff
<span>
<b>Things</b>
<h2>Stuff</h2>
<h3>Other</h3>
<h4>Grassy</h4>
<p>Not this</p>
<h5>More replace</h5>
</span>
</div>
</blockquote>
<b>Outside of the blockquote</b>
<h1>Should not be affected</h1>
<h2>Should not be affected either</h2>
"