import Foundation
let pattern = #"\"Id\":"(\d+)","LocalTime":"(\d+)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2020-06-05 01:00:33.919 INFO [Thread-261246][HClient.java:256] - post successefully
2020-06-05 01:00:33.920 INFO [Thread-261246][HClient.java:257] - {"ResponseStatusListObject":{"ResponseStatusObject":[{"RequestURL":"/VIID/Faces","StatusCode":"0","StatusMessage":"正常","Id":"31010713011328005232","LocalTime":"20200605005843"}]}}
2020-06-05 01:00:33.920 INFO [Thread-261246][PutuoHandle.java:104] - list send end, listSize:6, sendTime:757ms
2020-06-05 01:00:34.160 INFO [Thread-261248][HClient.java:256] - post successefully
2020-06-05 01:00:34.160 INFO [Thread-261248][HClient.java:257] - {"ResponseStatusListObject":{"ResponseStatusObject":[{"RequestURL":"/VIID/Faces","StatusCode":"0","StatusMessage":"正常","Id":"31010712011328005082","LocalTime":"20200605010212"}]}}
2020-06-05 01:00:34.196 INFO [Thread-261247][HClient.java:256] - post successefully
2020-06-05 01:00:34.196 INFO [Thread-261247][HClient.java:257] - {"ResponseStatusListObject":{"ResponseStatusObject":[{"RequestURL":"/VIID/Faces","StatusCode":"0","StatusMessage":"正常","Id":"31010712011328005082","LocalTime":"20200605010240"}]}}
2020-06-05 01:00:34.196 INFO [Thread-261247][PutuoHandle.java:104] - list send end, listSize:5, sendTime:954ms
2020-06-05 01:00:34.323 INFO [Thread-261248][HClient.java:256] - post successefully
2020-06-05 01:00:34.323 INFO [Thread-261248][HClient.java:257] - {"ResponseStatusListObject":{"ResponseStatusObject":[{"RequestURL":"/VIID/Faces","StatusCode":"0","StatusMessage":"正常","Id":"31010713011328005232","LocalTime":"20200605005843"}]}}
2020-06-05 01:00:34.510 INFO [Thread-261248][HClient.java:256] - post successefully
2020-06-05 01:00:34.510 INFO [Thread-261248][HClient.java:257] - {"ResponseStatusListObject":{"ResponseStatusObject":[{"RequestURL":"/VIID/Faces","StatusCode":"0","StatusMessage":"正常","Id":"31010711011328005078","LocalTime":"20200605010240"}]}}
2020-06-05 01:00:34.510 INFO [Thread-261248][PutuoHandle.java:104] - list send end, listSize:5, sendTime:1464ms
2020-06-05 01:00:48.939 INFO [Timer-0][PutuoHandleThread.java:29] - area=>PT_AREA cameraType=>HK_TP groupCount=>3
2020-06-05 01:00:48.939 INFO [Timer-0][DbUtil.java:118] - getLastMaxId, cameraType:HK_TP, area:PT_AREA
2020-06-05 01:00:48.940 INFO [Timer-0][DbUtil.java:129] - sql=SELECT maxid FROM t_flag_info WHERE cameraType = ? AND area = ?, 1:HK_TP, 2:PT_AREA
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)