re = /^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/m
str = 'test@domain.com
$other@gmail.com
invalid@^domain.com
^(*&(@gmail.com
"&^(*()&%&^%"@gmail.com
something@*.google.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end