package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)\s*\bMYISAM\b`)
var str = `CREATE TABLE t (i INT) MYISAM;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}