$re = '/.*\[(\d+)\]/';
$str = 'obj.foo[0].bar[0].name';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);