const regex = /([P.$?]\$|[]^]P|G\]\$|CG)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([P.$?]\\$|[]^]P|G\\]\\$|CG)$', 'mg')
const str = `PPCG
^P
^[P^]P
[^?][PG]\$
(?<!\\\\..)(?!]).\$
^[\\w^]*\$|!|]P|G]\\\$\$
!|[^?]P(CG|G..)?\$
[^])]\\\$|^\\^?P|P.\\].\$
([.\$?]|G\\])\\\$\$|^\\^?P|\\]P\$
[PPCG]
^[P\\^]
[^\\]]\$
^\\^?P
[^?][PG]\$|<|PG
^[^\\\\|]*(\\\\\\\\)+[^\\\\|]*[^\\]]\$
^(.{,4}|.{9}|.{16,19}|.{5}P)\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}