$re = '/\w+\@\w+\.(com|ru|net)/m';
$str = 'mail@mail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);