$re = '/^\n?((?:[^|]+\|){2}[^\n]+)/m';
$str = 'aaa|xyz|pqr
another|column
with
line break | last column';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);