import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".* \\w+ (?=\\()|(\\(\\d{4}_\\d{2}_\\d{2}\\s\\d{2}_\\d{2}_\\d{2}\\s\\w{3}\\))";
final String string = "\n"
+ "Acacia tree 2 (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
+ "Acacia tree 2 (2015_12_03 14_18_17 UTC).jpg\n"
+ "JOURNEY TO ARABIA (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
+ "Acacia Tree 4 (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg\n\n\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\AFRICA THE MOTHER OF US ALL 3 (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\AFRICAN MAN + CROCODILE (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\AFRICAN MAN + CROCODILE (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\AFRICAN MAN + CROCODILE (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\African muslim with favorite slave (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\African muslim with favorite slave (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\African muslim with favorite slave (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\amagufwa ya bene Rwanda (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\amagufwa ya bene Rwanda (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\amagufwa ya bene Rwanda (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ama-Rank y' inyenzi (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ama-Rank y' inyenzi (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ama-Rank y' inyenzi (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Amenhotep_III (1) (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Amenhotep_III (1) (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Amenhotep_III (1) (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Amenhotep_III (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Amenhotep_III (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Amenhotep_III (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\amenhotep3_head_03 (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\amenhotep3_head_03 (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\amenhotep3_head_03 (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\an Egyptian [Sudanese woman] (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\an Egyptian [Sudanese woman] (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\an Egyptian [Sudanese woman] (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\an Egyptian [Sudanese woman]2 (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\an Egyptian [Sudanese woman]2 (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\an Egyptian [Sudanese woman]2 (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Ancient Africa How Europeans have it wrong - Kevin MacDonald (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Ancient Africa How Europeans have it wrong - Kevin MacDonald (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Ancient Africa How Europeans have it wrong - Kevin MacDonald (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ancient African script (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ancient African script (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ancient African script (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Ancient African Scripts (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Ancient African Scripts (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Ancient African Scripts (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ancient African writings (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ancient African writings (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ancient African writings (2015_12_03 14_18_17 UTC).png\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\ANCIENT HEBREWS DWELLINGS (2014_10_06 13_06_05 UTC) \n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Bamwe mu basigajwe inyuma n’amateka bo mu Mudugudu wa Bukamba - LEVITES (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Baobab (Adansonia digitata) and elephant, Tanzania (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg\n"
+ "D:\\Kmna\\Desktop\\FACE-PICTS\\RAW MATERIALS\\Baobab (Adansonia digitata) and elephant, Tanzania (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}