use strict;
my $str = '^9F33006E0F848^00950108080008000^9F37008B1832B33^9F1E0163236353132303337^9F26016B9F12AB2FA191854^9F36003003F^00820041980^009C00200^9F1A0040643^009A006210114^9F02012000000058700^5F2A0040643^9F03012000000000000^9F2700280^9F340061F0002^9F3500222^0084014A0000006581010^9F090040002^9F41006023804^9F100640FA501A030002000ED085B191CB9E97C10040000000000000000000000000000';
my $regex = qr/(?<my_field>9F10.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}