// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([A-Za-z]{3,9}:(\/\/))([-;:&=\+\$,\w]+)[.]([-;:&=\+\$,\w]+)[.]([-;:&=\+\$,\w]+))(?:([.-;:&=\+\$,\w\/]*))$").unwrap();
let string = "https://blo23423423---4234g3.asd23423423asdas.uk.com/sdfs.com/first.html
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}